Overview

So you’re working with SLES or SLED, and someone asks you if a particular package or product is supported. What do you do? Of all the options available, I refer constantly to the following pages and references to make sure I give accurate and helpful information to the querying person.

Where to Go

The top page I usually refer people to in this case is the Tech Specs section. On this page is listed SLES, SLED and Partner hardware and software support links. If I click on the “SuSE Linux Enterprise Server” link, I will reach the technical specifications page for SuSE Linux Enterprise Server. We’ve seen this page in other posts, such as How Many ____’s Does SLES Support? – Part I, where we discussed Kernel Limits and File System Features.

The chief thing I want to determine when someone asks me about a particular package’s support is that we do include it in our distributions. I query the person about what version and patch level they want to know about, and then click on the appropriate link, which is listed in the paragraph below the menu tabs, “see the list of supported packages”.

This link leads me to the “SuSE Linux Enterprise Server Supported Packages page, where for example I will pick the link for “SuSE Linux Enterprise Server 10 SP1 for X86“, a PDF file that I can then search for a package by pressing Ctrl-f, and typing the name I’m looking for, either in my browser, or my PDF reader that popped up.

All Together Now

My example would be someone asking me if there is support for Mono (a Dot Net compatible server solution) on SLES 10 SP1, both on the X86 and System Z platforms.

Those PDF files will tell me very quickly that there is support all the way to Level 3 for SLES 10 SP1 on X86 and the IBM System Z Mainframe.

Hopefully this will help you determine quickly what packages are included in the various distributions and patch levels, and make it easier to find what level of support is provided for those packages.

Enjoy,

RossB

Advertisements